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Introduction 

Software developed by collectors for collectors. 

mCollector.net LLC has been developing collector software for over two 
decades.  NM Collector CP software is the latest edition in a line of successful 
packages used by individual collectors to track and manage their collections.  
Our intent is to keep NM Collector CP relevant and up to date for the 

foreseeable future so it will be the last edition you will ever need. 

This manual is intended to be a complete description of the software with detailed 
operating instructions.  It is formatted such that it can be printed and placed in a binder 
for those, like me, who like to have paper copies of documents.  The latest version of 
this user manual and other sources of information including our blog and our support 
pages can be found at www.nmcollector.net 

References 

Some useful resources can be found on these pages. 

• Our ecommerce site can be found at:  www.nmcollector.net 

• Lots of usage hints and information at:  https://www.nmcollector.net/blog 

• NM Gun Collector Software:  https://www.nmcollectorsoftware.org/ 

• NM Collector JE Software:  https://nmcollectorsoftware.com/ 

• NM Collector CP Software:  https://nmcollectorsoftware.us/ 

• NM Collector Software Support Desk:  
https://nmcollector.atlassian.net/servicedesk/customer/portals 
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General Concepts 

Manage any collection on any platform. 

he intent of this software is to provide the flexibility for you to manage any type 
of collection using the terminology and content that you want to use.   Defaults 
are provided for many types of collections which can be used as is or modified 
to suit your preferences. 

Collection Templates 

Collection templates  are used to manage captions that appear on the pages.  Values can 
be changed as needed.  Values that appear in dropdowns can also be modified.  New 
templates can be created from scratch or from an existing template. 

Available Field Types 

Data is captured in a variety of field types.   

1. Drop down fields  allow you to select text from a drop-down list.  Field values can 
be added, modified, and deleted. 

2. Number fields  capture any numbers relevant to the item.  Formatting is not 
applied because a number field can be used for any number (pun intended) of 
formats. 

3. Date fields  are used to capture important dates. 

4. Notes fields  allow you to capture larger amounts of text.  

Operating Systems 

This collection management software can be run on Windows, Mac, and Linux.  It can 
be run from a USB flash drive but the data will be stored on the system in which the 
USB is plugged into.  Data can be exported  from one platform and imported  into the 
other. 

Mobile Apps 

Companion mobile apps are available for iOS and Android devices.  Data can be 
transferred between devices.  See Android and iOS sections below for more details. 

Acquisition and Activation 

This software is available via download or can be delivered on a USB flash drive.  The 
download provides a full featured 30 day evaluation period.  After that it will convert to 
a free version with fewer features. The full feature version can be activated with the 
purchase  of an annual subscription.  The USB option can only be purchased with a 
subscription. 

T 



 

 

3 

NOTES:   

• When the 30-day evaluation  expires and the software reverts to the free version, 
data will not be lost and will become available again after the purchase of a 
subscription to activate  the full features. 

• You can still export all of your data even after the subscription has expired so 
you are not locked in if you ever decide not to renew your activation. 

Installation  and Startup  

Installation and startup depend on the operating system. 

nce downloaded, you must decide how you want to run the software.  The 
specific options and procedures depend on the operating system as 
referenced below.   

USB Flash Drive  
 

USB File Structure: 

 

• NMCollectorCP_Win.zip 

• NMCollectorCP_Mac.zip 

• NMCollectorCP_Linux.zip 

• USB Instructions 
 

USB Instructions: 

 
This USB flash drive contains NM Collector Software CP deployments for Windows, Mac, and Linux operating systems.  
Each deployment is contained in a zip file.  There is also an activation file that is used to activate the software.  The 
activation time period depends on the purchase option you chose.  Please use [Activation > Apply] and navigate to the 
activation.lic file included on the USB Flash Drive to apply your activation to your copy of NM Collector Software. 
 
Please copy the zip file for the operating system you want to use to the computer that you want to use it on.  Once 
you have copied the zip file to your system extract the contents of the zip file to whatever location you choose. 
 
For Windows, Mac, and Linux you can run the program from the files you extracted.  For Windows and Mac you also 
have an installation option.  Once you have extracted the contents to your computer you will see an Instructions txt 
file for that operating system.  Please follow the instructions in that file. 
 
Also included in each zip file is a detailed User Manual for your reference. 
 
NOTES:   

1. You can extract the files to the USB and run the program there but the data will be stored on the computer 
that you have the USB flash drive plugged into 

2. Please do not attempt to extract the contents to your USB flash drive on a Linux system.  There will be 
errors. 

  

O 
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Windows  
 

Installation 

1. Download nmCollectorCP.zip 

2. Extract contents to computer hard drive or USB 

3. Optional - run setup program (Setup NMCollectorCP.exe) which can be found in 
the installer directory 

Startup 

1. If you used the installer, you can run from the shortcut created on the desktop or 
the installed nmCollectorCP.exe 

2. You can also open the downloaded directory and double click the 
nmCollectorCP.exe 

Mac  
 

Installation 

1. Download nmCollectorCP.zip 

2. Extract contents to computer hard drive or USB 

3. Optional - run setup program (NMCollectorCP.dmg) which can be found in the 
installer directory 

Startup 

1. If you used the installer, you can run NM Collector CP from your applications 
folder 

2. You can also open the downloaded directory and double click the 
nmCollectorCP.app 

Linux  
 

Installation 

1. Download nmCollectorCP.zip 

2. Extract contents to computer hard drive or USB 

3. This will create the NMCollector_Linux directory which contains the application 

4. For reports to work, you must also install Microsoft fonts (Arial in particular).   

 NOTE: Please follow the instructions found here:  
https://lexics.github.io/installing-ms-fonts 
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Startup 

1. Open a Terminal window in the NMCollectorCP_Linux directory 

Option 1 :   

a. From desktop, navigate to the NMCollectorCP_Linux folder,  

b. right click on it and  

c. select "Open in terminal" from the dropdown list 

Option 2: 

d. Open a Terminal window 

e. cd to the NMCollectorCP_Linux directory 

2. Start the NMCollectorCP application from the Terminal Window with:  

sh run.command 
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Operation 

Operation is consistent across all operating systems. 

inux will have some minor variations but, other than that, the features and 
operation are the same across all desktop operating systems.  Companion mobile 
apps are generally consistent but have some differences. 

 

Main Page  

 

 

FIGURE 1 The Main page of the application where items are listed. 

This page is the center of control of the application.  The collection is selected from the 
drop down and items for that collection are listed on the page.  Clicking on an item in 
the list will take you to the data for that item. 

L 
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Title Bar  

The title bar contains the name of the application, the current version you are running, 
and the subscription (activation) expiration date. 

Menu Bar  

The menu bar gives you access to reports, file functions, edit features, options, activation 
(subscription), and help. 

Collection Drop Down  

The collection drop down contains a list of the available collections.  Selecting a 
collection  loads the template for that collection and the list of items in that collection. 

Add (Item) Button  

This button adds a new item to the selected collection and opens the identification tab 
for you to enter key values for identifying this new item . 

Sort (Item) Button  

This will change the sort order of the items displayed between ascending and descending. 

Filter (Search) Field  

Enter values in this field to filter what items are displayed.  Only items that match the 
filter will be displayed.  Click the check mark displayed in the field or hit return to apply 
the filter.  Click the X displayed in the field to clear the filter. 

Stats Button  

Clicking this button will open the statistics page where data is displayed in a table format 
and summaries are calculated.  Please see the statistics description below. 

Print Button  

This button opens a printable report containing the currently listed items.  If the list is 
filtered then only those filtered items will show up in the report. 

List of Items  

The rest of the page consists of a list of items in the collection.    Clicking on an item in 
the list takes you to the Identification (ID) tab for that item.  Other tabs also become 
available.  Each of these tabs is covered below. 
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Statistics Page  

 

 

FIGURE 2 The Statistics page. 

Clicking the Stats button on the Main page opens this page which displays a complete 
list of values and some stats for the selected collection.  Click on a header to change the 
sort order of the data.  Click a row to open the ID page for the clicked item. 

Hint:  Use the Search field to quickly find items on the page.  In fact, for very 
large collections, it is faster to jump directly to this statistics page to find items 
of interest than to wait for all of the items to load on the main page. 
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Reports 

 

Canned Reports 

 

Note:  These are not available in mobile apps. 

 

FIGURE 3.A The Canned Reports page. 

Clicking [Reports > Canned] from the Main page menu opens this page which provides 
an interface for selecting from available predefined reports.  The Select Collection and 
Select Item drop downs are enabled and disabled depending on what report you select. 

If you are handy with Jasper Reports you can develop your own predefined canned 
reports as well.  
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Custom Reports Feature 

 

Note:  These are not available in mobile apps. 

 

FIGURE 3.B The Custom Reports page. 

Clicking [Reports > Custom] from the Main page menu opens this feature which allows 
you to select fields that you want to display in a report.  Once you have defined a report 
configuration you click the [Open Report] button to display it.   

Unlike the canned reports, these are dynamically generated so they cannot be predefined 
in Jasper Reports.  Instead, an HTML file of the report named dynamicReport.html is 
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generated and stored on your local file system in your NM Collector CP data reports 
directory (see [Help > About] for that directory location on your system).  It is then 
opened for display and print by your default web browser. 

 

FIGURE 3.C Sample Custom Report 

You can also save your report configuration with the [Save Report Config] button.  It 
will be saved in a file named with the report title you entered and extension of .rept in 
the location (directory) you choose.  You can load it using the [Load Report Config] 
button.  This saves you from having to re-enter the criteria every time you want to load 
the same report. 

You can optionally filter those fields to limit results that appear in the report.  This can 
get a little complicated and produce unexpected results if you add too many options.  
Here are some suggestions: 

• It is best to add filters to the end if you will have multiple filters. 

• If an item is missing from a report, it could be that you added a field for a record 
that does not yet exist.  For example, if you want to see the receipt date but no 
receipt has been entered you will not see the item that has no receipt date. 

• When there is more than one filter the default is to use AND conjunctions. 
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• OR conjunctions can produce unexpected results.   

• You cannot use comparison operators (=,  !=, >,  <) on dates. 

• != means “Not Equal” 

Print Page Report Buttons 

 

 

FIGURE 3.D Print Button for Identification Tab 

This button can be found on many tabs.  When clicked it will open a printable report for 
that tab. The Print Page Report is generated dynamically, like the Custom Reports 
feature, and displayed in your web browser.   

Note: Mobile apps do not automatically open a web page to display the report.  You 
must first save the report to your file system and then open it from there. 
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ID Page  

 

 

FIGURE 4 The Identification page. 

This page is the center of control for an individual item.  Not only does it display key 
identification information, but it also provides buttons for duplicating, deleting, and even 
moving an item from one collection to another. 

Duplicate (Item) Button  

This feature will replicate the current item’s identification, description, and receipt 
information a selected number of times.  This is useful for entry of multiple similar items. 

Move (Item) Button  

You can move an item from one collection to another with this feature. 

Delete (Item) Button  

After confirmation, this will delete the current item from the database. 

Print Button  

Prints currently displayed data.  See reports section of this manual. 
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Fields 

Data available to capture in the ID tab makes up the rest of the page.  Each drop down 
field has three buttons to the right of it. 

1. + 

The + button adds a value to the drop-down list for that field. 

2. x 

The x button clears the value for that field. 

3. e 

The e button opens up the Edit DDL Page (please see below) allowing you to edit 
the values in the drop-down list. 

Edit Drop Down List (DDL) Page  

 

 

FIGURE 5 The Edit Drop-down List page. 
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This page allows you to edit the drop-down list contents for the selected field.  It should 
be self-explanatory except … if you delete a value that is in use by any item, that value 
will be automatically added back to the drop down list. 

Description Page  

 

 

FIGURE 6 The Description page. 

Here description information can be captured.  It can be difficult at times to distinguish 
between identification and description information.  I like to think of identification 
information as that which uniquely identifies the item.  Description information is not 
required to uniquely identify the item.  You can decide what fields you consider to be 
identification and description by customizing your collection template to suit your needs. 
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Pictures Page  

 

 

FIGURE 7 The Pictures page. 

Capture one or more pictures and associated data for the selected item. 

NOTES:   

• A primary objective is to preserve your data.   

o When you remove a picture from an item, that picture is not deleted 
from the Picture Path.  It is just removed from the database for that 
item. 

o If you try to add a new picture that has the same name as a current 
picture for that item stored in the Picture Path, the old picture will not 
be replaced by the new picture.  If you want to remove the old picture 
you must manually delete it from the file system. 
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• If you copy the database from one system to another the pictures will not load 
unless they are also manually copied to the specified Picture Path.  This will not 
work if you copy from one operating system to another. For example, copy from 
Windows to Linux will not work because the paths will be a different format. 

• Better to export (discussed elsewhere) your data from one system and then 
import it into the other.  This will transfer the pictures as well. 

Add (Picture) Button  

Navigate to a picture on your file system to associate with this item.  Only .jpg, .jpeg, 
.bmp, .gif and .png images are accepted.  The original picture will be left in its original 
location and a copy of it will be placed in a designated location for your operating system.  
The original location and new location are captured and displayed in the first two fields 
located below the picture.  

Drag and Drop Picture  

You can drag a picture from anywhere and drop it in the “Drop Here” field.  Only .jpg, 
.jpeg, .bmp, .gif and .png will be accepted in the “Drop Here” field.  

Remove (Picture) Button  

This feature will replicate the current item’s identification, description, and receipt 
information a selected number of times.  This is useful for entry of multiple similar items. 

Picture Scroll Bar  

You can scroll through pictures using the “<” and “>” buttons located on either side of 
the current picture field which shows up as a number representing the current picture 
“of” a number representing the total number of pictures. 

Picture Display Options  

Just above the upper right corner of the picture you can select how you want the picture 
displayed.  The options are FIT, FILL, FILL_NO_DISTORTIONS, FILL_WIDTH, 
FILL_HEIGHT, and NONE.  Rather than trying to explain each of these options it is 
better for you to experiment with them to see for yourself how they work. 
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Receipt Page  

 

 

FIGURE 8 The Receipt page. 

Capture receipt information for the selected item. 
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Disposition Page  

 

 

FIGURE 9 The Disposition page. 

Capture disposition information for the selected item. 
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Related Items Page  

 

 

FIGURE 10 The Related Items page. 

In some cases you may find that one item is related to one or more other items.  This 
page allows you to capture those relationships. 
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Add Related Item Page  

 

 

FIGURE 11 Add Related Item page. 

Here you can specify a new related item for the selected item. 
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Maintenance Page  

 

 

FIGURE 12 The Maintenance page. 

Capture one or more maintenance tasks and associated data for the selected item. 

Duplicate (Maintenance) Button  

Use the duplicate button when you want to complete a maintenance operation.  That 
way you do not have to re-create previously defined maintenance operations each time 
you repeat them.  

Add (Maintenance) Button  

This allows you to add a new maintenance operation with detailed tasks.  Once entered 
the duplicate button described above can be used to capture every time the maintenance 
is performed.   

Remove (Maintenance) Button  

This will delete the current maintenance operation.   
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Maintenance Scroll Bar  

You can scroll through maintenance records using the “<” and “>” buttons located on 
either side of the current maintenance record field which shows up as a number 
representing the current maintenance record “of” a number representing the total 
number of maintenance records.  Maintenance records are stored in reverse 
chronological order so the most recent records are displayed first. 

Events Page  

 

 

FIGURE 13 The Events page. 

Capture one or more events and associated data for the selected item.  This is essentially 
the same page as the Maintenance page covered earlier. 
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Data Sheet Page  

 

 

FIGURE 14 The Data Sheet page. 

Data Sheets are a popular way to captured detailed data on components of U.S. World 
War II firearms which were manufactured with interchangeable parts by design.  From 
a practical perspective, this is nothing but a really big free form field for you to enter 
whatever data you want. 
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Links Page  

 

 

FIGURE 15 The Links page. 

Add links to anything!  This will capture whatever link you add and open the link when 
you click on it.  You can add links to web pages, documents (including word, pdf, etc.) 
and even pictures. 

Add (Link) Button  

Navigate to any and select it.  You can also drag and drop any file or web page. 

Add a description if you want.  



 

 

26 

Add Link Page  

 

 

FIGURE 16 Add Link page. 

Copy and paste or drag and drop to add a link to the currently selected item. 

Drag and Drop Link  

You can drag a link from anywhere and drop it in the “Drop Here” field.   
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Features Available Through 

the Menu  

The menu provides many features to enhance and support general 
operations. 

eatures and functionality available through the menu are described here.  These 
do not logically fit in the general operations but are very important for 
configuration, data transfers, backup, and recovery. 

 

Export Menu  

 

When exporting data, please keep in mind that the [Help > About] menu item will open 
the About page (see discussion elsewhere) which will show you where the files are 
exported to.  This location varies by operating system. 

 

FIGURE 17 File > Export > … 

Current Collection Template  

This is how you export your collection template which defines all of the field names for 
a collection.  This is a good way to share your collection template definitions with other 
users who can import your template for their own use. 

F 
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Current Collection Items to CSV  

You can export all of the data for the currently selected item to a .csv file which is 
compatible with Excel and other spreadsheet programs.  Pictures associated with each 
item will be stored in a pictures folder named after the item number.   The item number 
is a behind the scenes number that you do not see in the user interface and is used to 
uniquely identify each item. 

Export To Data Transfer  

Use this feature along with the corresponding import to “synch” your data on all of the 
platforms (Windows, Mac, Linux, iOS, Android) you use.  This exports your database 
and all associated pictures in a new folder named CP_Data_Transfer which you can copy 
from one platform to another for importing to the other platforms. 

 

Import Menu  

 

When importing data, please keep in mind that the [Help > About] menu item will open 
the About page (see discussion elsewhere) which will show you where files were exported 
to.  This location varies by operating system. 

 

FIGURE 18 File > Import > … 

Collection Template  

This allows you to import collection definitions exported by you or others into your copy 
of NM Collector CP. 

Items From CSV  

Use this feature to import data that was exported from NM Collector CP.  You can use 
this to transfer data from one operating system to another.  This is also used along with 
the NM Collector JE to CP Data Migration tool to import JE data into CP. 
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From Data Transfer 

Use this feature along with the corresponding export to “synch” your data on all of the 
platforms (Windows, Mac, Linux, iOS, Android) you use.  This imports your database 
and all associated pictures.  It requires the folder named CP_Data_Transfer which you 
create with the Export > To Data Transfer feature. 

 

Reports Menu  

 

Note:  These are not available in mobile apps. 

  

FIGURE 19 Reports 

Selecting the Reports menu option will allow you to select Canned or Custom Reports 
(discussed earlier). 

Backup Database Menu  

 

Notes:   

• Backup Database is not available in mobile apps.  Use Data Transfer 
instead. 

• Backup Database does not backup pictures. If you want to backup both 
your database and pictures use the "Export > To Data Transfer" feature 
instead. 
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FIGURE 20 Backup Database 

Selecting this menu option will save the database to a location that you specify.  There is 
also an automatic backup that happens whenever you start the program.  This automatic 
backup can be disabled in the [File > Options] menu. 

 

Recover Database Menu  

 

Note:  Recover Database is not available in mobile apps.  Use Data Transfer instead. 

 

FIGURE 21 Recover Database 

Selecting this menu option will allow you to navigate to a location where a database 
backup is stored so you can recover to that database. The default location that opens is 
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where the automatic backups are stored.  You can select the backup you want based on 
the date and time when the backup was saved.  You can also navigate to a different 
location if you manually saved a backup.  The database you select will replace your 
current data so choose wisely. 

Note: The program will shut itself down after recovery. 

 

 

 

 

 

Edit Menu  

 

 

FIGURE 22 File > Edit > … 

Edit Collections  

Opens the Edit Collections Page (see below) 
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FIGURE 23 Edit Collections Page.  Click the Template button to edit the collection template (See below)  

 

Edit Collection Templates  

Opens the Edit Template page (see below).   
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FIGURE 24 Edit Collection Template Page.  Here you can edit any caption for any field on any tab.  Remember the field types 

discussion above?  The far right drop down allows you to select the field type that you want to edit the captions for. 

 

Edit Tab Labels  

You do not like the current tab labels?  You can change them to whatever you want here.  
Keep them short so they fit in the tabs! 
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FIGURE 25 Edit Tab Labels. 

Options Enable/Disable Backups  

Automatic backups are enabled by default but they can be disabled through this menu 
option.  After they have been disabled you can go back here to enable them.   

 

FIGURE 26 Options > Enable/Disable Backups. 

Activation Menu 

Here you can [View] the status of your activation, open the eCommerce site to 
[Purchase] an activation, and [Apply] a purchased activation after you have downloaded 
it from the activation email you will receive after purchase.  If a new activation is applied, 
the activation file will be loaded and the expiration date will be updated to match the 
current subscription.  
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FIGURE 27 Activation. 

Help > About Menu 

 

 

FIGURE 28 Help Menu options. 

About Page 

This is a very useful page when you are trying to figure out where certain files exist on 
your system.  One of the most important ones is the Exports directory.  This is where 
you go to find exported data. 
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FIGURE 29 About Page. 

 

Support 

Sends you to the NM Collector CP support site. 
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Companion Apps 

 

General 

Complimentary Mobile apps have been developed for both Android and iOS devices.  
File management tools on these devices can be used to transfer data to and from the 
desktop applications and/or between devices.  Some general considerations for all 
mobile apps include the following: 

• Although you can export the collection template and values (for use in the 
Desktop app), you cannot import them.  Use the Data Transfer import instead 
to bring in the entire database and all definitions. 

• When using the Print button on a tab, the mobile apps do not automatically 
open a web browser.  You must first save the report to your file system and then 
use your file system browser to navigate to it and open it. 

iOS 

The iOS app conforms to Apple standards for iOS apps so it should feel familiar to iOS 
users.  Special considerations for the iOS app include the following: 

• The iOS app uses hard coded directories including the Export directory.  You 
can find the location of your Export directory using the Help > About menu 
item.  All exports will go to this directory and all Imports access data in this 
directory.  To transfer data into your iOS from another system, use the iOS file 
manager to copy the new data into the Export directory. 

• Generally, that Export directory can be access through your iOS file manager as 
“On My iPhone > nmCollectorCP > Exports.” 

• Accordingly, the CP_Data_Transfer directory can be found in “On My iPhone 
> nmCollectorCP > Exports > CP_Data_Transfer.” 

• I like to use iCloud to facilitate transfers of files between the desktop application 
and the iOS app. 

Android 

The Android app conforms to Android standards for Android apps so it should feel 
familiar to Android users.  Special considerations for the Android app include the 
following: 

• The Android app allows you to select an external folder for exports and imports. 

• Use the Android File Manager to access external folders. 

• You can use the Windows File Manager to copy files to and from your Android 
device. 
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NM Collector CP Software Version History  

 
Version 2.1 Released 03/30/2023 

• Simplified transfer of data between platforms. 

• Automatically convert existing 10 year activations to lifetime activations. 
 

Version 2.0 Released 11/12/2021 

• Simplified addition of new item data for large collections 

• Custom (Dynamically generated) Reports 

• Print Page Reports 

• Fixed JE import missing pictures 
 
Version 1.0 Released 10/25/2021 

• Activation 
 

Version 0.7 Released 10/10/2021 

• Events Tab 

• Maintenance Tab 

• Links Tab (including capture of PDFs) 

• Statistics Page 
 
Version 0.6 Released 9/16/2021 

• Move item from one collection to another 

• Ensure sort order of JE exported pictures is retained when imported into CP 

• Related Items Tab 

• Export/Import Data 

• Export Collection Template  

• Import Collection Template 

• Duplicate Template 
 
Version 0.5 Released 8/16/2021 

• Automated Backup (with recovery option) – can be enabled/disabled 

• Better manage file selection (restrict to valid options, remember paths)  

• Remember last selected collection for next time application is started 

• Fix Linux bugs related to usage of File System 

• Edit Tab Labels 

• Edit Collections 

• Edit Template Captions 

• Duplicate Item 

• [Help > About] with key information for support 

• Set last collection viewed to open by default 

• Clear Disposition in case entered by accident 
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Version 0.4 Released 7/15/2021 

• Canned Reports 

• Datasheet Tab 

• Import from JE (ID, Description, Receipt, Disposition, Pictures, Data Sheets) 

• Increase width of Add Pictures button on Linux 

• Performance improvements for large volumes of data 
 
Version 0.3 Released 7/15/2021 

• Manage Pictures 
 
Version 0.2 Released 6/25/2021 

• Add and Delete Items 

• Filter (search) items in the list 

• Change the sort of items in the list 

• Add to drop down lists (DDLs) values 

• Identification information 

• Description information 

• Receipt 

• Disposition 
 

Version 0.1 Released 5/14/2021 

• Technology and general architecture proof of concept. 


